UK-SSGTI
Would you like to react to this message? Create an account in a few clicks or log in to continue.

not running right

Go down

not running right  Empty not running right

Post  kane 22/01/11, 04:18 pm

basically, my '89 swift gti, is not running right on idle and hesitates when pulling away. I have changed the spark plugs, distributer cap, cleaned idle screw out. Is there anything else I should check?

Thanks

Kane
kane
kane

Posts : 56
Join date : 2009-05-16

Back to top Go down

not running right  Empty Re: not running right

Post  hobo 22/01/11, 05:21 pm

try cleaning airflow meter
hobo
hobo

Posts : 593
Join date : 2010-03-19
Age : 31
Location : norfolk (long stratton)

Character sheet
first car: 5

Back to top Go down

not running right  Empty Re: not running right

Post  Almondo74 23/01/11, 07:19 am

try checking for a vacuum leak
Almondo74
Almondo74

Posts : 959
Join date : 2009-07-25
Age : 31
Location : Cornwall

Character sheet
first car: Swift GL

https://www.facebook.com/profile.php?id=100001716634958

Back to top Go down

not running right  Empty Re: not running right

Post  dominator 23/01/11, 05:15 pm

fuel filter

dominator

Posts : 1296
Join date : 2008-03-16
Age : 41
Location : bournemouth

Character sheet
first car: renult 5 ts (1.7!)

Back to top Go down

not running right  Empty Re: not running right

Post  kane 23/01/11, 06:45 pm

i dont think it a air leak i clean the mass air flow out and i do have a fuel fiter and by looking at the oil filter today its look like the car has not been service in a long time i will try it tomorrw
thanks
kane
kane

Posts : 56
Join date : 2009-05-16

Back to top Go down

not running right  Empty Re: not running right

Post  Almondo74 23/01/11, 11:37 pm

when my fuel filter was fooked it idled fine, slightly hesitant but the main problem was hills and wouldnt gain or hold revs
Almondo74
Almondo74

Posts : 959
Join date : 2009-07-25
Age : 31
Location : Cornwall

Character sheet
first car: Swift GL

https://www.facebook.com/profile.php?id=100001716634958

Back to top Go down

not running right  Empty Re: not running right

Post  dominator 24/01/11, 05:52 pm

if it isnt the filter, have a look at the afm wireing, but that only affects it above 2krpm
it will idle for a while but as soon as you give it a bit of throtle it will die
also have a look at the tps, but again it affects more of the normal driving than tick over
how about the ignition timing?
have you checked the cam pully possitions?
how about the dreaded crankshaft key?

gary

dominator

Posts : 1296
Join date : 2008-03-16
Age : 41
Location : bournemouth

Character sheet
first car: renult 5 ts (1.7!)

Back to top Go down

not running right  Empty Re: not running right

Post  hobo 24/01/11, 05:56 pm

just thinking and i used to have a problem with idling and it turned out to be the lambada sensor
hobo
hobo

Posts : 593
Join date : 2010-03-19
Age : 31
Location : norfolk (long stratton)

Character sheet
first car: 5

Back to top Go down

not running right  Empty Re: not running right

Post  kane 24/01/11, 09:03 pm

it a 89 no lambda sensor on it
kane
kane

Posts : 56
Join date : 2009-05-16

Back to top Go down

not running right  Empty Re: not running right

Post  kane 30/01/11, 04:53 pm

been play around with car today i change the fuel filter and didnt break the bolts the car ran a bit better but not right so i put a brake pipe clamp on the fuel return olny done it up a bit and the idle was better and didnt seem to hesitate so am guess there got to be shit in the tank or the pump is on it last legs so just wondering how hard is it to get the tank out or can u cut a hole in the back under the seat
thanks kane
kane
kane

Posts : 56
Join date : 2009-05-16

Back to top Go down

not running right  Empty Re: not running right

Post  Almondo74 30/01/11, 10:47 pm

i woudlnt cut a hole personally its close to the underside of the floor, its just 4 bolts, disconnect the fuel pump connector, fuel filler hose, flow return and evap hose's and it drops easily.
better to empty the tank first tho or it will be quite heavy.

id try and put a fuel pressure guage before the fuel rail first to see if its constant pressure all the time before i ripped the tank out.
and if u need a pump the 1's on ebay work fine for £30-40 just need to make electrical connection. better than payin £300 from suzuki or motor factors.
ill post the link if u want to no.

Ross
Almondo74
Almondo74

Posts : 959
Join date : 2009-07-25
Age : 31
Location : Cornwall

Character sheet
first car: Swift GL

https://www.facebook.com/profile.php?id=100001716634958

Back to top Go down

not running right  Empty Re: not running right

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum