UK-SSGTI
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Shitty engine mounts

Go down

Shitty engine mounts Empty Shitty engine mounts

Post  jesseswiftgti 28/03/11, 05:06 pm

hey i just put engine in my swift and when i was doing up the bolts to the rear engine mount 1 of the threds in the block was fucked, it tightens a tiny bit then goes loose again so theres is only 3 in there strong and 1 in bit shit do you think it will be ok, im only going to use this engine tempary till i build a new engine, think i might get some lock tight just to hold it in a little more but aint going to do shit ?

maybe buy front strut brace off garndi cus it has extra engine support on it ?
jesseswiftgti
jesseswiftgti

Posts : 506
Join date : 2010-03-19

Character sheet
first car: 5

Back to top Go down

Shitty engine mounts Empty Re: Shitty engine mounts

Post  gtpswift 28/03/11, 06:13 pm

If three are in there and torque up properly you'll probably be OK, Thread lock will do nothing. How long is 'temporarily', If its longer than a month or two pull it out and helicoil it.

GTP

gtpswift

Posts : 398
Join date : 2009-05-25
Location : Melbourne Australia

Back to top Go down

Shitty engine mounts Empty Re: Shitty engine mounts

Post  jesseswiftgti 28/03/11, 08:07 pm

it aint going to be running for about 2 months mate just want to find myself a good block to work with and build it up and put it in
jesseswiftgti
jesseswiftgti

Posts : 506
Join date : 2010-03-19

Character sheet
first car: 5

Back to top Go down

Shitty engine mounts Empty Re: Shitty engine mounts

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum