UK-SSGTI
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Temp Gauge showing cold all the time!

Go down

Temp Gauge showing cold all the time! Empty Temp Gauge showing cold all the time!

Post  shuja 10/02/10, 06:42 pm

Hi
I've just bought a new Mk2 Ph1. I drove it down from brum and the temperature gauge showed cold all the way. I therefore checked the car over. Thermostat is working, fan turns on, hot air comes out of internal fan, changed the cold start sensor and the temp sensor from a running car.
Still it shows cold. I took a good look at the gauge and it does go up very slightly. My conclusion is that the actual gauge is broken inside.
I want to know if this is a common problem with the Ph1? Can I fix the same gauge by opening it up? Do I need to get a new gauge or a whole new cluster? Can anyone supply me the needed parts second hand?

shuja

Posts : 274
Join date : 2009-04-11

Back to top Go down

Temp Gauge showing cold all the time! Empty Re: Temp Gauge showing cold all the time!

Post  STEVEGTI 10/02/10, 07:46 pm

the sensor wire that goes onto the gauge sensor on the side of the head its a female crimp on single wire one.


earth it to the engine gauge should fly right up if so it aint the gauge

steve

_________________
Bringing back the old school
STEVEGTI
STEVEGTI
Admin

Posts : 1835
Join date : 2008-03-02
Age : 32
Location : london

Character sheet
first car: suzuki swift gti

http://www.uk-ssgti.com

Back to top Go down

Temp Gauge showing cold all the time! Empty Re: Temp Gauge showing cold all the time!

Post  shuja 12/02/10, 05:39 pm

cheers. Will do that this weekend

shuja

Posts : 274
Join date : 2009-04-11

Back to top Go down

Temp Gauge showing cold all the time! Empty Re: Temp Gauge showing cold all the time!

Post  shuja 13/02/10, 03:01 pm

Just a few tips. I've never opened a instrument cluster on these before. Is it all just front opening? Is there any chance of it being the actual mechanisms inside the gauge? If its just wiring it should'nt be a problem

shuja

Posts : 274
Join date : 2009-04-11

Back to top Go down

Temp Gauge showing cold all the time! Empty Re: Temp Gauge showing cold all the time!

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum