UK-SSGTI
Would you like to react to this message? Create an account in a few clicks or log in to continue.

engine problem

Go down

engine problem Empty engine problem

Post  Gedis 13/12/10, 08:55 pm

got a serious problem with my engine, under acceleration, terrible tapping noise, little power, struggles to reach 5k rpm, these symptoms are under load (while driving), funny thing is that it idles fine, if stationary the engine revs fine without any noises until about 5k, then you can hear slight tapping and it struggles a little, and if i'm driving but accelarating slowly, no noises, the car runs fine, oh and when you're starting the car it feels like one of the cylinders doesn't want to work, the engine vibrates more than usual, but after a few seconds it's fine

will check compression, timing, tps sensor, if something's messed up with the internals, shouldn't there always be a tapping noise? no blue smoke, no black smoke, no white smoke, oil is fine, coolant is fine too, will keep an eye on those.

Any suggestions what to look for? without taking the engine apart...

Suggestions are welcomed,

Regards

Ged

Gedis

Posts : 173
Join date : 2010-09-09

Back to top Go down

engine problem Empty Re: engine problem

Post  hobo 13/12/10, 09:01 pm

from what you wrote i would be inclined to pop the rocker cover off and check your cams lifters and valves
hobo
hobo

Posts : 593
Join date : 2010-03-19
Age : 31
Location : norfolk (long stratton)

Character sheet
first car: 5

Back to top Go down

engine problem Empty Re: engine problem

Post  Gedis 13/12/10, 09:51 pm

i've got another set of lifters, will clean them, and swap them, will update this when i do that

how should i inspect the valves, by just taking the rocket cover off?

Gedis

Posts : 173
Join date : 2010-09-09

Back to top Go down

engine problem Empty Re: engine problem

Post  stevieh6 14/12/10, 12:35 pm

id say, make sure its just the head tapping and not the bottom end, then swap the head for a working one, if its head and bottom end then its an engine swap.

stevieh6
stevieh6

Posts : 495
Join date : 2008-03-03
Age : 40
Location : Norfolk

Back to top Go down

engine problem Empty Re: engine problem

Post  daymoon 14/12/10, 07:24 pm

i'd say it is something to do with timing belt/dizzy

daymoon

Posts : 288
Join date : 2009-10-03
Age : 30
Location : Selby, North Yorkshire

Back to top Go down

engine problem Empty Re: engine problem

Post  Gedis 14/12/10, 08:07 pm

timing is ok, belt position ok, i think it's the bottom, will check compresion soon, i don't think the head is damaged, there was no reason for the valves to bend unless something gotten into the intake...

will check the bottom end on the other engine, if the cilinders are ok, it will go in and will put the head from the one in the car.

Gedis

Posts : 173
Join date : 2010-09-09

Back to top Go down

engine problem Empty Re: engine problem

Post  Gedis 17/12/10, 04:37 pm

so ummm yeah, the engine kind of runs nicer and nicer everyday for some reason... right now i'm in WTF??!?! mode, didn't do anything yet, still a bit slow on high rpms 5k+ but everything else is fine...
must be the gremlins again...

Gedis

Posts : 173
Join date : 2010-09-09

Back to top Go down

engine problem Empty Re: engine problem

Post  daymoon 17/12/10, 04:50 pm

I wonder if some moister got into wiring and now it is drying out?

daymoon

Posts : 288
Join date : 2009-10-03
Age : 30
Location : Selby, North Yorkshire

Back to top Go down

engine problem Empty Re: engine problem

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum